Aperture 1.5.6 PowerBook G4 12″ installation hack

I bought myself during this Christmas a Canon Digital IXUS 860 IS compact cam (a personal review will come in further posts).

This my new hobby made me realize I need some photo management software. I own iLife 08 from Apple, which includes iPhoto 08 (simple for basic tasks) but I’m really considering use another app more powerful. I came across to the, yet sometimes flame war, discussion between LightRoom and Aperture.

While trying to install Aperture 1.5.6 (trial version, btw) I received the following message:

“Your video card does not meet the minimum requirements to run this software”.

Howcome is this possible, if the Aperture Compatiblity Checker app certifies successfully my laptop?

Looking into Aperture hardware minimum requirements I have ensured in Apple site that it should work on my laptop, which is a:

  • Powerbook G4 1.5 ghz
  • 1.25 Gb RAM
  • 80 Gb Disk
  • 12″ LCD display
  • Nvidia GeForceGo 5200 64Mb DDR

After tinkering around with the Aperture installer I have found a way to overcome the installation checks in order to install it on every Mac you own (I won’t guarantee your hardware can run Aperture, but at least you can now install it. :) ):

  • Copy the ApertureTrial.mpkg inside the .dmg image into your hard disk somewhere
  • Ctrl+Click in the ApertureTrial.mpkg in your hard disk and choose “Show Package Contents”
  • Go inside “Contents” folder and edit ApertureTrial.dist file with your favorite text editor
  • Delete the line containing: and save it
  • Now run the ApertureTrial.mpkg again.

Cool! You will be able to install Aperture without verifying hardware requirements first.

Poking into the installationCheck() script, the GeForceGo 5200 seams to be blacklisted by Apple (still don’t know the reason). Even thouhg it does not perform extremely fast, it works fine to me. No problems found yet.

Hope it helps :).